Hoe enkel positieve of negatieve getallen optellen in Excel?

Hoe enkel positieve of negatieve getallen optellen in Excel?

Heb je positieve en negatieve waarden staan in 1 kolom in Excel en wil je enkel de positieve en/of de negatieve optellen? Zo doe je het.

We maken dit duidelijk aan de hand van een eenvoudig voorbeeld. Hou je je inkomsten en uitgaven bij in Excel en staat alles mooi onder elkaar in 1 kolom waarbij je inkomsten positieve getallen zijn en je uitgaven negatieve getallen?

Hoe kun je nu weten hoeveel geld er binnenkomt en hoeveel geld er buitengaat? Als je alle getallen in de kolom optelt bekom je je netto resultaat. Dit is de som van je totale inkomsten min de som van je totale uitgaven.

Om alle getallen op te tellen, bestaat de functie SOM in Excel (SUM voor de Engelse versie). In kolom B12 uit ons voorbeeld staat dus deze formule:

=SOM(B2:B11)

Het resultaat kan negatief, 0 of positief zijn:

  • Bij 0 zijn  je inkomsten en uitgaven perfect in balans. De kans dat je 0 uitkomt is dus behoorlijk kleinšŸ˜‰.
  • Bekom je een negatief getal, dan heb je meer uitgaven dan inkomsten wat vraagt om een bijsturing want op die manier ga je er niet op vooruit maar op achteruit.
  • Bekom je een positief getal, dan hou je geld over op het einde van de maand en kun je sparen. Dit is wat je wil bereiken want op die manier kun je je dromen verwezenlijken.

Enkel positieve of negatieve getallen optellen

In bovenstaand voorbeeld houden we dus 155ā‚¬ over. Maar wat als we nu onze totale inkomsten en onze totale uitgaven willen weten?

Om enkel positieve (of negatieve) getallen op te tellen, kun je de functie SOM.ALS gebruiken (of SUMIF voor de Engelse versie).

In bovenstaand voorbeeld is de formule voor de totale inkomsten in kolom B13:

=SOM.ALS(B2:B10;”>0″)

en de formule voor de totale uitgaven in kolom B14:

=SOM.ALS(B2:B10;”<0″)

SOM.ALS functie

Deze functie kun je als volgt gebruiken:

SOM.ALS(bereik;criterium;[optelbereik])

Hierbij is het bereik de cellen in je document die je wil controleren op een criterium. In bovenstaand voorbeeld is het bereik de cellen B2:B10.

Het criterium is de voorwaarde waaraan voldaan moet worden om de cel mee te laten nemen in de optelling. In ons voorbeeld staat daar bij de  totale inkomsten “>0” om enkel positieve getallen te laten meetellen.

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *